FuelPHP – 任意のコードが実行される脆弱性

FuelPHP には、Request_Curl クラスの処理に問題があり、任意のコードが実行される脆弱性が存在します。

FuelPHP は、ウェブアプリケーションを作成するためのフレームワークです。FuelPHP には、Request_Curl クラスの処理に問題があり、任意のコードが実行される脆弱性が存在します。

——————————————————————————–

【影響を受けるシステム】
下記のバージョンを使って作成された FuelPHP アプリケーションが本脆弱性の影響を受けます:

  • FuelPHP バージョン 1.1 から 1.7.1 まで

 

 

——————————————————————————–

【対策方法】

開発者が提供する情報をもとにフレームワークを最新版に更新してください。